Connecting to the Game

For the discussion of general topics about the game.
Lorelie
Sword Journeyman
Sword Journeyman
Posts: 141
Joined: Tue Feb 26, 2008 2:52 am

Connecting to the Game

Post by Lorelie » Fri Sep 15, 2017 5:17 pm

Is anyone else having problems connecting to the game? I get a connection to the host but the login screen never loads, or it does load but freezes on me logging in.

Vaemar
Sword Grand Master
Sword Grand Master
Posts: 664
Joined: Fri Jun 05, 2015 11:21 am

Re: Connecting to the Game

Post by Vaemar » Fri Sep 15, 2017 6:00 pm

Several people on the Discord were reporting impossibility to connect to the game, especially I had the impression this hit users from North America.

I was unable to connect in the same way you describe from around 2 p.m. GMT up to around 7 p.m. GMT, and now I am able to play again, although with a certain amount of lag, as I experienced also yesterday.

When it wants to work, disconnecting and reconnecting seems to fix it.

Yemin
Sword Grand Master
Sword Grand Master
Posts: 1589
Joined: Fri Feb 07, 2014 3:08 pm
Location: On the back of castle oblivion

Re: Connecting to the Game

Post by Yemin » Fri Sep 15, 2017 6:30 pm

It was extremely laggy this morning about 10 AM GMT ish.

To the point I had to log out or risk dying in the Agro zone I was in.
I trained up double-edged bananas because the uber-plantain of doom I scored from the beehive quest was the best weapon in the game. Now it's being treated like a bug and they have gimped its damage! That's not fair! My character is ruined!

Yemin
Sword Grand Master
Sword Grand Master
Posts: 1589
Joined: Fri Feb 07, 2014 3:08 pm
Location: On the back of castle oblivion

Re: Connecting to the Game

Post by Yemin » Fri Sep 15, 2017 6:52 pm

As of right now I can't connect,

Heavy lag seems to be the reason as I'm not recieving any errors client side and when I try and reconnect it behaves as if its connecitng to the server
I trained up double-edged bananas because the uber-plantain of doom I scored from the beehive quest was the best weapon in the game. Now it's being treated like a bug and they have gimped its damage! That's not fair! My character is ruined!

User avatar
Zethanon
Sword Master
Sword Master
Posts: 201
Joined: Wed Dec 05, 2012 11:31 pm
Location: Zhentil Keep

Re: Connecting to the Game

Post by Zethanon » Fri Sep 15, 2017 7:06 pm

It takes me multiple attempts but after at least 5 I can connect with no lag after the login screen.

My mobile connection doesn't even have troubles, immediately works. But I'm connecting via the same Wi-Fi signal, so it's a little stange that mobile is zero troubles while my zMUD seems caught up.
You'll shed your blood, your bodies fall. That is the price you'll pay to cleanse you of your sins. Vicious and cruel, let's kill them all.
Let's kill them all.

User avatar
Ailyn
Sword Master
Sword Master
Posts: 200
Joined: Sat Nov 14, 2015 4:53 pm

Re: Connecting to the Game

Post by Ailyn » Fri Sep 15, 2017 9:26 pm

I have been having the issue with CMUD, however anytime I try on my phones BlowTorch app, it connects no issue. And here I thought it was just me.
He who fights with monsters might take care lest he thereby become a monster. And if you gaze for long into an abyss, the abyss gazes also into you. ~Friedrich Nietzsche

Noella
Sword Bumbler
Sword Bumbler
Posts: 3
Joined: Wed Sep 13, 2017 10:17 pm

Re: Connecting to the Game

Post by Noella » Fri Sep 15, 2017 10:01 pm

I'm also having issues connecting to the game via Mudlet. On one occasion it allowed me to connect earlier today, but it took an astounding amount of attempts and then once I left I was once again cut off from FK. For the record, the game was somewhat lagging while I was online today, when it did allow me to connect. I don't think it has anything to do with my own personal internet or MUD client as everything else is right as rain.

User avatar
Zethanon
Sword Master
Sword Master
Posts: 201
Joined: Wed Dec 05, 2012 11:31 pm
Location: Zhentil Keep

Re: Connecting to the Game

Post by Zethanon » Fri Sep 15, 2017 10:05 pm

Ailyn wrote:however anytime I try on my phones BlowTorch app, it connects no issue.
Same here. And it connects quickly with little lag whether I'm on Wi-Fi or 1 bar of 4G mobile signal. Strange strange.
You'll shed your blood, your bodies fall. That is the price you'll pay to cleanse you of your sins. Vicious and cruel, let's kill them all.
Let's kill them all.

Vaemar
Sword Grand Master
Sword Grand Master
Posts: 664
Joined: Fri Jun 05, 2015 11:21 am

Re: Connecting to the Game

Post by Vaemar » Fri Sep 15, 2017 10:31 pm

Also, it seems MUDportal works fine for playing, but not vt100 support: http://www.mudportal.com/play

Ghan
Sword Bumbler
Sword Bumbler
Posts: 6
Joined: Tue Sep 05, 2017 10:58 pm

Re: Connecting to the Game

Post by Ghan » Sat Sep 16, 2017 1:30 am

Coming up on 9:30pm est. Haven't been able to get past the very first "Connected to " line since I got home ~3hours ago. I'm running out of news to watch instead of playing :(

User avatar
Daerin
Sword Novice
Sword Novice
Posts: 42
Joined: Tue Mar 08, 2016 12:42 am

Re: Connecting to the Game

Post by Daerin » Sat Sep 16, 2017 3:36 am

I too am experiencing issues, and have been for most of the week, using Cmud and Mudlet. I can't play on mobile, it makes my brain hurt. XD Anyone have any ideas how to fix things?

Lyndin
Sword Novice
Sword Novice
Posts: 31
Joined: Tue Jun 06, 2017 11:50 am

Re: Connecting to the Game

Post by Lyndin » Sat Sep 16, 2017 4:03 am

If the game's administrators wouldn't mind, we could try to set up a proxy from some endpoint that has a decent connection to the server. I'm sure we could get a AWS micro or something along those lines going without too much effort. Of course, that comes with a natural risk: you're sending your username and password to the proxy, not directly to the MUD.

Lyndin
Sword Novice
Sword Novice
Posts: 31
Joined: Tue Jun 06, 2017 11:50 am

Re: Connecting to the Game

Post by Lyndin » Sat Sep 16, 2017 4:21 am

I was able to connect to the mud using PuTTY and SOCKS proxies from Brazil and the United Kingdom. For reference, I'm from California and was experiencing issues.

https://www.socks-proxy.net/ has a bunch of free proxies, but you do have to take a leap of faith and trust the proxies with your credentials.

Lorelie
Sword Journeyman
Sword Journeyman
Posts: 141
Joined: Tue Feb 26, 2008 2:52 am

Re: Connecting to the Game

Post by Lorelie » Sat Sep 16, 2017 6:55 pm

I wanted to note that I am still having trouble. I was able to get on after about twenty attempts to connect. I am on now and the game is a big laggy.

Ghan
Sword Bumbler
Sword Bumbler
Posts: 6
Joined: Tue Sep 05, 2017 10:58 pm

Re: Connecting to the Game

Post by Ghan » Sat Sep 16, 2017 10:11 pm

Similar to Lorelie, a few hours ago, I got in. The game played normally for about 20 minutes, then tanked. Haven't gotten back in since.

Aysa
Sword Grand Master
Sword Grand Master
Posts: 266
Joined: Sun Jan 26, 2014 9:37 pm
Contact:

Re: Connecting to the Game

Post by Aysa » Sat Sep 16, 2017 10:39 pm

The MudPortal site works... just need to change the color profile. Anything gray is hard to read.

Areia
Sword Grand Master
Sword Grand Master
Posts: 482
Joined: Fri Feb 12, 2016 11:11 pm

Re: Connecting to the Game

Post by Areia » Sat Sep 16, 2017 11:38 pm

I don't doubt it's being looked into. Just have to give it some time.

Until then, just so peoples know, I won't be around. I can likewise connect by phone, but it's essentially impossible for me to play that way. So if there are any hopefuls or anyone else who needs Areia, she'll catch you when possible.
Nascentes morimur, finisque ab origine pendet.

Brelc
Sword Novice
Sword Novice
Posts: 33
Joined: Wed Jun 10, 2015 3:54 am

Re: Connecting to the Game

Post by Brelc » Sat Sep 16, 2017 11:58 pm

FYI..

I am still having the same issues as everyone else. However, downloading and connecting VIA putty is working. Just set it to telnet forgottenkingdoms.org port 4000.

Not a perfect fix but it seems stable so far.

Lyndin
Sword Novice
Sword Novice
Posts: 31
Joined: Tue Jun 06, 2017 11:50 am

Re: Connecting to the Game

Post by Lyndin » Sun Sep 17, 2017 2:46 am

I'm surprised to report that putty works for me even without a proxy, though it still drops/lags on occasion. It seems to do so less often when I enable TCP keepalives, but that might just be confirmation bias. I wonder what putty does differently than most mud clients and the native telnet client?

Noella
Sword Bumbler
Sword Bumbler
Posts: 3
Joined: Wed Sep 13, 2017 10:17 pm

Re: Connecting to the Game

Post by Noella » Sun Sep 17, 2017 3:38 am

Putty also works for me, but I don't think that this necessarily means that the issue is client based. There's a few things I've noticed in the past few days that dispute this.

1) The forums themselves. I've noticed that I can enter the forums and browse to my hearts content on my phone but when I do so with my PC I often get a page that says the page cannot be reached or something similar in nature. This is after a long wait for it to say anything at all.

*As of this post, and I'm writing this bit last, a second tab I have opened with the FK Forums currently says "Waiting for response from". I took my time with this post too, so I'm not sure what is going wrong.

*edit* I'm not sure if this is helpful, but I just noticed that after a forum page times out it will immediately load on a refresh. Takes awhile for it to time out though.

2) MUD clients on my phone work well, but anything with my PC is lagging or simply cannot get passed connection established. The only exception was Putty here, it worked okay when I tried it. Mudportal worked, but I'm not sure if the lag I was getting was from the awful interface they have or the server itself. (For reference, it's the same Wi-Fi. I'm not using phone data.)

3) The few times in the past couple of days that Mudlet has managed to get me into the game have been met with some ugly lag that comes and goes. I checked other MUDs with mudlet, just to be sure. They all seem to work.

In short, I don't really think it's the clients or my own connection to blame, but considering that my phone allows me to connect with next to no lag, I can't agree with the idea that it's the server either.

Post Reply